#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<input[^>]*type="file"[^>]*>"
Local $sString = "<input type="text" name="username">" & @CRLF & _
"<input type="file" name="upload_file">" & @CRLF & _
"<input type="submit" value="Submit">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")