using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<input[^>]*type=""file""[^>]*>";
string input = @"<input type=""text"" name=""username"">
<input type=""file"" name=""upload_file"">
<input type=""submit"" value=""Submit"">";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}