$re = '#<input[^>]*type="file"[^>]*>#i';
$str = '<input type="text" name="username">
<input type="file" name="upload_file">
<input type="submit" value="Submit">';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);