import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<input[^>]*type=\"file\"[^>]*>";
final String string = "<input type=\"text\" name=\"username\">\n"
+ "<input type=\"file\" name=\"upload_file\">\n"
+ "<input type=\"submit\" value=\"Submit\">";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}