package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<input[^>]*type="file"[^>]*>`)
var str = `<input type="text" name="username">
<input type="file" name="upload_file">
<input type="submit" value="Submit">`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}