re = /<input[^>]*type="file"[^>]*>/i
str = '<input type="text" name="username">
<input type="file" name="upload_file">
<input type="submit" value="Submit">'
# Print the match result
str.match(re) do |match|
puts match.to_s
end