package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?<style>[0-9]*)\\\\(?<color>[0-9]*)\\\\(?<size>[a-zA-Z0-9-]*(\\\\[.])?)(\\\\)?(?<lenght>(\\["])?[0-9]*(\\["])?)`)
var str = `70270\\1073\\34\\
83122\\1073\\38-42
92422\\1167\\L
70234\\1167\\38\\34\"
70242\\1001\\29\\.
70222\\3040\\29\\32\"
70267\\1019\\30
81086\\1309\\XL
70246\\1001\\38\\\"32
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}