import Foundation
let pattern = #"(?<style>[0-9]*)\\\\(?<color>[0-9]*)\\\\(?<size>[a-zA-Z0-9-]*(\\\\[.])?)(\\\\)?(?<lenght>(\\["])?[0-9]*(\\["])?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .allowCommentsAndWhitespace])
let testString = #"""
70270\\1073\\34\\
83122\\1073\\38-42
92422\\1167\\L
70234\\1167\\38\\34\"
70242\\1001\\29\\.
70222\\3040\\29\\32\"
70267\\1019\\30
81086\\1309\\XL
70246\\1001\\38\\\"32
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)