$re = '/(?<style>[0-9]*)\\\\\\\\(?<color>[0-9]*)\\\\\\\\(?<size>[a-zA-Z0-9-]*(\\\\\\\\[.])?)(\\\\\\\\)?(?<lenght>(\\\\["])?[0-9]*(\\\\["])?)/ix';
$str = '70270\\\\1073\\\\34\\\\
83122\\\\1073\\\\38-42
92422\\\\1167\\\\L
70234\\\\1167\\\\38\\\\34\\"
70242\\\\1001\\\\29\\\\.
70222\\\\3040\\\\29\\\\32\\"
70267\\\\1019\\\\30
81086\\\\1309\\\\XL
70246\\\\1001\\\\38\\\\\\"32
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);