// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?ix)(?<style>[0-9]*)\\\\(?<color>[0-9]*)\\\\(?<size>[a-zA-Z0-9-]*(\\\\[.])?)(\\\\)?(?<lenght>(\\["])?[0-9]*(\\["])?)"#).unwrap();
let string = "70270\\\\1073\\\\34\\\\
83122\\\\1073\\\\38-42
92422\\\\1167\\\\L
70234\\\\1167\\\\38\\\\34\\\"
70242\\\\1001\\\\29\\\\.
70222\\\\3040\\\\29\\\\32\\\"
70267\\\\1019\\\\30
81086\\\\1309\\\\XL
70246\\\\1001\\\\38\\\\\\\"32
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}