# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/AND op.OP(\d{1,2})(OPVerfahren.*?\))/AND op.OP$1$2 \n GROUP BY OP$1OPVerfahren/gms;t' <<< " AND op.OP1OPVerfahren > 0
AND p.Testzwecke = 0
AND NOT EXISTS (SELECT DISTINCT 1 FROM ods01.dat_optherapie op2 WHERE op2.patID = p.ID AND op2.revision > op.revision)
UNION ALL
AND op.OP2OPVerfahren > 0
AND p.Testzwecke = 0
AND NOT EXISTS (SELECT DISTINCT 1 FROM ods01.dat_optherapie op2 WHERE op2.patID = p.ID AND op2.revision > op.revision)
UNION ALL"