import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "AND op.OP(\\d{1,2})(OPVerfahren.*?\\))";
final String string = " AND op.OP1OPVerfahren > 0\n"
+ " AND p.Testzwecke = 0\n"
+ " AND NOT EXISTS (SELECT DISTINCT 1 FROM ods01.dat_optherapie op2 WHERE op2.patID = p.ID AND op2.revision > op.revision)\n"
+ " UNION ALL\n\n"
+ " AND op.OP2OPVerfahren > 0\n"
+ " AND p.Testzwecke = 0\n"
+ " AND NOT EXISTS (SELECT DISTINCT 1 FROM ods01.dat_optherapie op2 WHERE op2.patID = p.ID AND op2.revision > op.revision)\n"
+ " UNION ALL";
final String subst = "AND op.OP$1$2 \\n GROUP BY OP$1OPVerfahren";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}