import re
regex = re.compile(r"AND op.OP(\d{1,2})(OPVerfahren.*?\))", flags=re.MULTILINE | re.DOTALL)
test_str = (" AND op.OP1OPVerfahren > 0\n"
" AND p.Testzwecke = 0\n"
" AND NOT EXISTS (SELECT DISTINCT 1 FROM ods01.dat_optherapie op2 WHERE op2.patID = p.ID AND op2.revision > op.revision)\n"
" UNION ALL\n\n"
" AND op.OP2OPVerfahren > 0\n"
" AND p.Testzwecke = 0\n"
" AND NOT EXISTS (SELECT DISTINCT 1 FROM ods01.dat_optherapie op2 WHERE op2.patID = p.ID AND op2.revision > op.revision)\n"
" UNION ALL")
subst = "AND op.OP$1$2 \\n GROUP BY OP$1OPVerfahren"
result = regex.sub(subst, test_str)
if result:
print(result)