// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)AND op.OP(\d{1,2})(OPVerfahren.*?\))").unwrap();
let string = " AND op.OP1OPVerfahren > 0
AND p.Testzwecke = 0
AND NOT EXISTS (SELECT DISTINCT 1 FROM ods01.dat_optherapie op2 WHERE op2.patID = p.ID AND op2.revision > op.revision)
UNION ALL
AND op.OP2OPVerfahren > 0
AND p.Testzwecke = 0
AND NOT EXISTS (SELECT DISTINCT 1 FROM ods01.dat_optherapie op2 WHERE op2.patID = p.ID AND op2.revision > op.revision)
UNION ALL";
let substitution = "AND op.OP$1$2 \\n GROUP BY OP$1OPVerfahren";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}