re = /AND op.OP(\d{1,2})(OPVerfahren.*?\))/m
str = ' AND op.OP1OPVerfahren > 0
AND p.Testzwecke = 0
AND NOT EXISTS (SELECT DISTINCT 1 FROM ods01.dat_optherapie op2 WHERE op2.patID = p.ID AND op2.revision > op.revision)
UNION ALL
AND op.OP2OPVerfahren > 0
AND p.Testzwecke = 0
AND NOT EXISTS (SELECT DISTINCT 1 FROM ods01.dat_optherapie op2 WHERE op2.patID = p.ID AND op2.revision > op.revision)
UNION ALL'
subst = 'AND op.OP$1$2 \\n GROUP BY OP$1OPVerfahren'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result