const regex = /AND op.OP(\d{1,2})(OPVerfahren.*?\))/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('AND op.OP(\\d{1,2})(OPVerfahren.*?\\))', 'gms')
const str = ` AND op.OP1OPVerfahren > 0
AND p.Testzwecke = 0
AND NOT EXISTS (SELECT DISTINCT 1 FROM ods01.dat_optherapie op2 WHERE op2.patID = p.ID AND op2.revision > op.revision)
UNION ALL
AND op.OP2OPVerfahren > 0
AND p.Testzwecke = 0
AND NOT EXISTS (SELECT DISTINCT 1 FROM ods01.dat_optherapie op2 WHERE op2.patID = p.ID AND op2.revision > op.revision)
UNION ALL`;
const subst = `AND op.OP$1$2 \n GROUP BY OP$1OPVerfahren`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);