#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z][a-zA-Z\d]{6,}\d$"
Local $sString = "afoohi5" & @CRLF & _
"3foobar5" & @CRLF & _
"afoobarz" & @CRLF & _
"afoo-bar5" & @CRLF & _
"afoobar5" & @CRLF & _
"Pfoobarbaz8"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")