package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z][a-zA-Z\d]{6,}\d$`)
var str = `afoohi5
3foobar5
afoobarz
afoo-bar5
afoobar5
Pfoobarbaz8`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}