using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Za-z][a-zA-Z\d]{6,}\d$";
string input = @"afoohi5
3foobar5
afoobarz
afoo-bar5
afoobar5
Pfoobarbaz8";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}