re = /^[A-Za-z][a-zA-Z\d]{6,}\d$/m
str = 'afoohi5
3foobar5
afoobarz
afoo-bar5
afoobar5
Pfoobarbaz8'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end