$re = '/^[A-Za-z][a-zA-Z\d]{6,}\d$/m';
$str = 'afoohi5
3foobar5
afoobarz
afoo-bar5
afoobar5
Pfoobarbaz8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);