using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\w:-]+$(?<!:)";
string input = @"aaa:bbb-cool
aaa:bbb-cool-
aaa-22-bbb_cool3
aaa:bbb-cool:
aaa_bbb-cool:
aaa_bbb-cool
bbbb:>dd
hihi%
大家好
0000000000
11111:2222:3333
11111:2222:3333:
DDD@@@1
大家好";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}