import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\w:-]+$(?<!:)";
final String string = "aaa:bbb-cool\n"
+ "aaa:bbb-cool-\n"
+ "aaa-22-bbb_cool3\n"
+ "aaa:bbb-cool:\n"
+ "aaa_bbb-cool:\n"
+ "aaa_bbb-cool\n"
+ "bbbb:>dd\n"
+ "hihi%\n"
+ "大家好\n"
+ "0000000000\n"
+ "11111:2222:3333\n"
+ "11111:2222:3333:\n"
+ "DDD@@@1\n"
+ "大家好";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}