const regex = /^[\w:-]+$(?<!:)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\w:-]+$(?<!:)', 'gm')
const str = `aaa:bbb-cool
aaa:bbb-cool-
aaa-22-bbb_cool3
aaa:bbb-cool:
aaa_bbb-cool:
aaa_bbb-cool
bbbb:>dd
hihi%
大家好
0000000000
11111:2222:3333
11111:2222:3333:
DDD@@@1
大家好`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}