#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?<=Box).*?(\d+)"
Local $sString = "PO Box : **32322 EG LM01" & @CRLF & _
"po BoX : 34243 ffafa" & @CRLF & _
"POBox 32323 sdfodah dada" & @CRLF & _
"DAJD Po box : 33122 sdfa" & @CRLF & _
"SAJDAH pO boX 424234 DSFS"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")