re = /(?<=Box).*?(\d+)/mi
str = 'PO Box : **32322 EG LM01
po BoX : 34243 ffafa
POBox 32323 sdfodah dada
DAJD Po box : 33122 sdfa
SAJDAH pO boX 424234 DSFS'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end