import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Box).*?(\\d+)";
final String string = "PO Box : **32322 EG LM01\n"
+ "po BoX : 34243 ffafa\n"
+ "POBox 32323 sdfodah dada\n"
+ "DAJD Po box : 33122 sdfa\n"
+ "SAJDAH pO boX 424234 DSFS";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}