use strict;
my $str = 'PO Box : **32322 EG LM01
po BoX : 34243 ffafa
POBox 32323 sdfodah dada
DAJD Po box : 33122 sdfa
SAJDAH pO boX 424234 DSFS';
my $regex = qr/(?<=Box).*?(\d+)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}