const regex = /(?<=Box).*?(\d+)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Box).*?(\\d+)', 'gmi')
const str = `PO Box : **32322 EG LM01
po BoX : 34243 ffafa
POBox 32323 sdfodah dada
DAJD Po box : 33122 sdfa
SAJDAH pO boX 424234 DSFS`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}