#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?x)" & @CRLF & _
"^" & @CRLF & _
"([^-]+) # Capture everything not a dash" & @CRLF & _
"\s+-\s+ # Match white space(s) dash white space(s)" & @CRLF & _
"((?1)) # Capture everything not a dash" & @CRLF & _
"\.mp3" & @CRLF & _
"$" & @CRLF & _
""
Local $sString = "My Test Name - h1n.mp3" & @CRLF & _
"Arist of Song - Title of song.mp3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")