const regex = /(?x)
^
([^-]+) # Capture everything not a dash
\s+-\s+ # Match white space(s) dash white space(s)
((?1)) # Capture everything not a dash
\.mp3
$
/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?x)
^
([^-]+) # Capture everything not a dash
\\s+-\\s+ # Match white space(s) dash white space(s)
((?1)) # Capture everything not a dash
\\.mp3
$
', 'gm')
const str = `My Test Name - h1n.mp3
Arist of Song - Title of song.mp3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}