import re
regex = re.compile((r"(?x)\n"
r"^\n"
r"([^-]+) # Capture everything not a dash\n"
r"\s+-\s+ # Match white space(s) dash white space(s)\n"
r"((?1)) # Capture everything not a dash\n"
r"\.mp3\n"
r"$\n"), flags=re.MULTILINE)
test_str = ("My Test Name - h1n.mp3\n"
"Arist of Song - Title of song.mp3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")