using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?x)
^
([^-]+) # Capture everything not a dash
\s+-\s+ # Match white space(s) dash white space(s)
((?1)) # Capture everything not a dash
\.mp3
$
";
string input = @"My Test Name - h1n.mp3
Arist of Song - Title of song.mp3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}