re = /(?x)
^
([^-]+) # Capture everything not a dash
\s+-\s+ # Match white space(s) dash white space(s)
((?1)) # Capture everything not a dash
\.mp3
$
/m
str = 'My Test Name - h1n.mp3
Arist of Song - Title of song.mp3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end