# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*(?:\p{So}|#\d+)//gm;t' <<< "Bana is goog for health
☑
#50
it is what
what
-Timing
☑
#51
Alignment
Interval Snapshots - Timing Alignment
☑
#49
Nous vous remercions - Reso
☑
#53
"