use strict;
my $str = 'Bana is goog for health
☑
#50
it is what
what
-Timing
☑
#51
Alignment
Interval Snapshots - Timing Alignment
☑
#49
Nous vous remercions - Reso
☑
#53
';
my $regex = qr/\s*(?:\p{So}|#\d+)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";