#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s*(?:\p{So}|#\d+)"
Local $sString = "Bana is goog for health " & @CRLF & _
"☑ " & @CRLF & _
"#50" & @CRLF & _
"" & @CRLF & _
"it is what " & @CRLF & _
"what " & @CRLF & _
"-Timing " & @CRLF & _
"☑ " & @CRLF & _
"#51 " & @CRLF & _
"Alignment" & @CRLF & _
"" & @CRLF & _
"Interval Snapshots - Timing Alignment " & @CRLF & _
"☑ " & @CRLF & _
"#49" & @CRLF & _
"" & @CRLF & _
"Nous vous remercions - Reso " & @CRLF & _
"☑ " & @CRLF & _
"#53" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)