package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*(?:\p{So}|#\d+)`)
var str = `Bana is goog for health
☑
#50
it is what
what
-Timing
☑
#51
Alignment
Interval Snapshots - Timing Alignment
☑
#49
Nous vous remercions - Reso
☑
#53
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}