import Foundation
let pattern = ##"\s*(?:\p{So}|#\d+)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
Bana is goog for health
☑
#50
it is what
what
-Timing
☑
#51
Alignment
Interval Snapshots - Timing Alignment
☑
#49
Nous vous remercions - Reso
☑
#53
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)