$re = '/\s*(?:\p{So}|#\d+)/m';
$str = 'Bana is goog for health
☑
#50
it is what
what
-Timing
☑
#51
Alignment
Interval Snapshots - Timing Alignment
☑
#49
Nous vous remercions - Reso
☑
#53
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;