#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\bhttps?:[\/]{2}[^\s"<]+\b\/*"
Local $sString = "<a href="http://example.com" rel="noreferrer">http://example.com</a>" & @CRLF & _
"<a href="http://example.com" onclick="alert(1);">link</a>" & @CRLF & _
"<a href="http://example.com">link</a>" & @CRLF & _
" ^^^^^^^"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")