const regex = /\bhttps?:[\/]{2}[^\s"<]+\b\/*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bhttps?:[\\\/]{2}[^\\s"<]+\\b\\\/*', 'g')
const str = `<a href="http://example.com" rel="noreferrer">http://example.com</a>
<a href="http://example.com" onclick="alert(1);">link</a>
<a href="http://example.com">link</a>
^^^^^^^`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}