package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bhttps?:[\/]{2}[^\s"<]+\b\/*`)
var str = `<a href="http://example.com" rel="noreferrer">http://example.com</a>
<a href="http://example.com" onclick="alert(1);">link</a>
<a href="http://example.com">link</a>
^^^^^^^`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}