re = /\bhttps?:[\/]{2}[^\s"<]+\b\/*/
str = '<a href="http://example.com" rel="noreferrer">http://example.com</a>
<a href="http://example.com" onclick="alert(1);">link</a>
<a href="http://example.com">link</a>
^^^^^^^'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end