using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bhttps?:[\/]{2}[^\s""<]+\b\/*";
string input = @"<a href=""http://example.com"" rel=""noreferrer"">http://example.com</a>
<a href=""http://example.com"" onclick=""alert(1);"">link</a>
<a href=""http://example.com"">link</a>
^^^^^^^";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}