$re = '/\bhttps?:[\/]{2}[^\s"<]+\b\/*/';
$str = '<a href="http://example.com" rel="noreferrer">http://example.com</a>
<a href="http://example.com" onclick="alert(1);">link</a>
<a href="http://example.com">link</a>
^^^^^^^';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);