#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^\*+.*\*+$\n)(?:.*\n)+?(?=^\*+.*\*+$\n)"
Local $sString = "********** Field #1 **********" & @CRLF & _
"Content inside Field #1" & @CRLF & _
"More content" & @CRLF & _
"" & @CRLF & _
"********** Field #2 **********" & @CRLF & _
"Content inside Field #2" & @CRLF & _
"More content" & @CRLF & _
"" & @CRLF & _
"********** Field #2 **********" & @CRLF & _
"Content inside Field #2" & @CRLF & _
"More content"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")