$re = '/(^\*+.*\*+$\n)(?:.*\n)+?(?=^\*+.*\*+$\n)/m';
$str = '********** Field #1 **********
Content inside Field #1
More content
********** Field #2 **********
Content inside Field #2
More content
********** Field #2 **********
Content inside Field #2
More content';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);