import re
regex = re.compile(r"(^\*+.*\*+$\n)(?:.*\n)+?(?=^\*+.*\*+$\n)", flags=re.MULTILINE)
test_str = ("********** Field #1 **********\n"
"Content inside Field #1\n"
"More content\n\n"
"********** Field #2 **********\n"
"Content inside Field #2\n"
"More content\n\n"
"********** Field #2 **********\n"
"Content inside Field #2\n"
"More content")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")