import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\*+.*\\*+$\\n)(?:.*\\n)+?(?=^\\*+.*\\*+$\\n)";
final String string = "********** Field #1 **********\n"
+ "Content inside Field #1\n"
+ "More content\n\n"
+ "********** Field #2 **********\n"
+ "Content inside Field #2\n"
+ "More content\n\n"
+ "********** Field #2 **********\n"
+ "Content inside Field #2\n"
+ "More content";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}